Xcode-select 安装

打开 Terminal,直接输入
xcode-select —install

按照步骤直接同意

验证安装成功没有:  再输入

xcode-select --install
如果出现如下,说明安装成功了
xcode-select: error: command line tools are already installed, use "Software Update" to install updates

解决更新Xcode以后使用Git报错的问题

解决办法:
第一步: 输入下面的命令
guofeng@guofengiMacBook-Air SecondApp$ sudo xcodebuild -license
Password:
第二步: 同意Xcode条款
输入密码后要求你必须同意下面两个Xcode条款.
You have not agreed to the Xcode license agreements. You must agree to both license agreements below in order to use Xcode.
Hit the Enter key to view the license agreements at '/Applications/Xcode.app/Contents/Resources/English.lproj/License.rtf'
按照提示点击Enter键来查看条款.
pple Inc.
Xcode and Apple SDKs Agreement
PLEASE SCROLL DOWN AND READ ALL OF THE FOLLOWING TERMS AND CONDITIONS CAREFULLY BEFORE USING THE APPLE SOFTWARE OR APPLE SERVICES.  THIS IS A LEGAL AGREEMENT BETWEEN YOU AND APPLE.  IF YOU AGREE TO BE BOUND BY ALL OF THE TERMS AND CONDITIONS, CLICK THE “AGREE” BUTTON.  BY CLICKING “AGREE” OR BY DOWNLOADING, USING OR COPYING ANY PART OF THIS APPLE SOFTWARE OR USING ANY PART OF THE APPLE SERVICES, YOU ARE AGREEING ON YOUR OW
By typing 'agree' you are agreeing to the terms of the software license agreements. Type 'print' to print them or anything else to cancel, [agree, print, cancel]
点击空格看到最后,输入agree来同意条款.
agree
You can view the license agreements in Xcode's About Box, or at /Applications/Xcode.app/Contents/Resources/English.lproj/License.rtf
然后就成功了 

Mac安装软件时提示已损坏或打开提示应该移除废纸篓的解决办法

常规报错解决方案一

2019年7开始,很多TNT破解软件大面积报错,具体原因不讨论,只讨论解决方案

步骤一:

安装xcode,这个在商店里面有,不想安装的,按步骤二来。

步骤二:

安装Command Line Tool 工具

打开终端输入以下命令

xcode-select --install (install前面为两个短横线)

步骤三:

终端继续输入以下命令

codesign --force --deep --sign - (force、deep、sign前面为两个短横线)

然后拖入需要签名的软件,最后类似于这样

codesign --force --deep --sign - /Applications/name.app (/Applications前面有一个空格)

回车搞定

常规报错解决方案二

不想知道原理和偷懒的,安装软件,直接给报错程序签名。

下载地址为:

链接:https://pan.baidu.com/s/1wpWjqKzHqNKqvznhIjZpCQ  密码:3riu

常规报错解决方案三

从本站下载的Sketch、Principle等设计软件,以及输入法等常用软件,安装时总是提示“已损坏,移至废纸篓”这类信息,根本无法打开。如下图:

Mac安装软件时提示已损坏的解决方法-麦氪派(WaitsUn.com | 爱情守望者)

其实,这是新系统(macOS Sierra 10.12.X)惹的祸。新系统加强了安全机制,默认不允许用户自行下载安装应用程序,只能从Mac App Store里安装应用。

解决方法

步骤一:打开终端(按F4启动Launchpad,终端默认在“其他”中)

Mac安装软件时提示已损坏的解决方法-麦氪派(WaitsUn.com | 爱情守望者)

步骤二:输入代码:

sudo spctl --master-disable(master前面为两个短横线,看下面的截图)
Mac安装软件时提示已损坏的解决方法-麦氪派(WaitsUn.com | 爱情守望者)

注意红框处应有空格
步骤三:按回车输入自己电脑密码,再次回车(密码不会显示出来,放心输就好)

Mac安装软件时提示已损坏的解决方法-麦氪派(WaitsUn.com | 爱情守望者)

不显示密码,输完按回车

步骤四:打开系统偏好设置 » 安全性与隐私,若显示任何来源,大功告成;若没有此选项,一定是你前面的步骤不对

Mac安装软件时提示已损坏的解决方法-麦氪派(WaitsUn.com | 爱情守望者)
回到桌面双击安装文件,发现都可以打开啦,尽情享受Mac带给你的乐趣吧!

常规报错解决方案四

32位程序不兼容,报类似以下的错误

Mac安装软件时提示已损坏的解决方法-麦氪派(WaitsUn.com | 爱情守望者)

终端输入

defaults write -g CSUIDisable32BitWarning -boolean TRUE